Please wait while we check your computer for required settings and plug-ins.

Critical Components

Component Compatible? Your Computer
Browser
Cookies Does not allow cookies
Javascript Yes Enabled

Less Critical Components

Component Compatible? Your Computer
Flash Not installed
Java Not installed
Operating System
Pop-up Blocker Pop-up windows disabled
Screen Resolution

Make Any Changes?

Changes may require you to restart your browser.

Troubleshoot Again

Browser

Top

Please use a supported browser or Connect may not display properly.

We support Firefox 25+, Internet Explorer 9, 10, 11, Google Chrome 31+ and Mac Safari 5+.

Download the latest version of one of these browsers:

Cookies

Top

Make sure your browser accepts cookies. Without cookies, you won't be to view assignments.

Firefox

Mac: Go to Firefox –> Preferences –> Privacy –> Select Accept cookies from sites
Windows: Go to Tools –> Options –> Privacy –> Select Accept cookies from sites

Internet Explorer

Go to Tools –> Internet Options –> Privacy –> Advanced

Safari

Mac: Go to Safari –> Preferences –> Security –> Select Always or Only from sites you navigate to
Windows: Go to Edit –> Preferences –> Security –> Select Always or Only from sites you navigate to

Javascript

Top

You need to enable JavaScript on your browser or Connect won't work properly.

Firefox

Windows: Go to Tools –> Options –> Content –> Select Enable JavaScript
Mac: Go to Firefox –> Preferences –> Content –> Enable JavaScript

Internet Explorer

Go to Tools –> Internet Options –> Security –> Custom Level –> Security –> Scripting –> Enable

Safari

Mac: Go to Safari –> Preferences –> Security –> Enable JavaScript
Windows: Go to Edit –> Preferences –> Security –> Enable JavaScript

Flash

Top

Please update your Flash plug-in. Without Flash, some assignment questions will not work correctly.

We support Flash Player 10.1.51.66 or higher.

Java

Top

Please install Java SE6 or higher.

The Java plug-in is required for both instructors and students. Instructors need Java to create assignment questions and to preview questions that use the Voiceboard. Students need Java to complete questions that use the Voiceboard.

Download the latest version

Operating System

Top

Please use a supported operating system.

At minimum, we support:
Windows: XP, Vista, Windows 7, Windows 8
Mac: OS X Snow Leopard 10.6, OS X Lion 10.7, OS X Mountain Lion 10.8, OS X Mavericks 10.9

Pop-up Blocker

Top

Make sure your pop-up blocker is turned off.

Screen Resolution

Top

This site supports a minimum resolution of 1024 x 768.

System Requirements

Operating Systems
  • Windows XP HE 2002 SP2, MS XP Pro 2002, MS Vista Home Premium edition, Windows 7, Windows 8
  • Mac OS X Snow Leopard 10.6, Mac OS Lion 10.7, Mac OS Mountain Lion 10.8, Mac OS Mavericks 10.9
Browsers
  • Firefox 25+
  • Internet Explorer 9, 10, 11
  • Google Chrome 31+
  • Safari 5.x, 6.x, 7.x (Mac)
Plug-ins
  • Flash 11+
  • Java SE6, SE7
  • Quicktime 7.7+
*Please Note: math, chemistry and engineering assignments require Chrome 31+, Firefox 25+, Safari 6+ and IE10 due to advanced formatting needs.

Customer Support

24 Hour Online Support:

Visit the Customer Support Site

Email the customer support team.